Author Topic: SP15 Laptop not charging battery  (Read 14215 times)

Offline lhulneTopic starter

  • Administrator
  • Newbie
  • *****
  • Posts: 27
    • ByteSpeed
SP15 Laptop not charging battery
« on: February 15, 2011, 08:32:10 AM »
We have found this issue to only affect the sp15 model of laptop. The symptom is a battery that will not charge, when in windows it shows a 0% charge and it will not exceed that amount. The following steps have been proven to fix the issue, if your battery still does not work after then it is a bad battery.


1)      Reflash the BIOS then the EC
2)      Laptop should shutoff after EC update, remove battery and power.
3)      Let sit for 5 minutes and put battery back in and plug power back in.
4)      Let charge overnight, should be good to go in the morning.
 
You can find the Bios and EC at the following site:
http://bytespeed.com/support/model/SP15

Both updates need to be ran from DOS, there is a supplied batch file with each download.
Lucas Hulne
Production Manager
ByteSpeed LLC
Toll Free: 888-658-0715
Fax: 218-227-0498
www.bytespeed.com

Wild Bill

  • Guest
Re: SP15 Laptop not charging battery
« Reply #1 on: February 22, 2011, 05:04:17 PM »
Here is a quick walkthrough of the flashing process.

You will need to make/have a DOS bootable flash drive. If you need a program to do this for you we have one up on our FTP site.
You can download it here:
ftp://support.bytespeed.com/dosboot.zip
User: bytespeed
Password: guest

Dosboot.zip will have a program and step by step instructions on how to create a bootable flash drive (you will need a flash drive that you can reformat). Once you have the flash drive bootable copy the bios902ec110oa folder from inside the zip to the flash drive.

Reboot the machine to the flash drive (F7 is the boot menu), once there type “cd bios902ec110oa” now type "cd 0902ec110" and hit enter again. Now run 1bios.bat, this will flash the BIOS. Once that is done run 2ec.bat. This will flash the EC and shutdown the machine. If you are running windows XP you will need to reboot the machine back to the flash drive and in the same folder run xpflash.bat. Now shutdown the machine and leave it plugged in for at least an hour to start a good charge on the battery. This should solve the battery charging issue.
« Last Edit: April 12, 2011, 10:53:08 AM by Wild Bill »

tlesmeister

  • Guest
Re: SP15 Laptop not charging battery
« Reply #2 on: August 26, 2013, 09:35:50 AM »
There have been some reports of these links either not working or the instructions being unclear. If you are having issues, please follow the instructions below:

Go to:
ftp://support.bytespeed.com/
User: bytespeed
Password: guest
 
Download the following links:
ftp://support.bytespeed.com/BIOS/SP15.zip
ftp://support.bytespeed.com/dosboot.zip
 
Extract all of the folders to your desktop or to a desired location.
 
Insert your flash drive and format it using quick format FAT32.

Run SP27608.exe.
 
Then, using the HP USB Disk Storage Format Tool, select the flash drive under Device, set File System to FAT32, enter a desired name for Volume Label, check Quick Format and Create a DOS Startup Disk, select “using DOS system files located at:” and point that directory to the “dos” folder you extracted from dosboot.zip, then click start.
 
Once the HP USB format is complete, copy the SP15 folder to the flash drive.
 
Power on the laptop, repeatedly press F7 at the American Megatrends splash screen, and select your USB flash drive as the boot device. You should then get a C:\ prompt, where you’ll want to type “cd sp15” and then run these two commands: 1bios, then 2ec. Your laptop should then power off, and you’ll want to disconnect the battery and AC adapter and press the power button a few times to drain excess power. Replace your battery and AC adapter and your battery should now be charging.
 
If you have any questions, feel free to call our helpdesk at (877)553-0777 or email us at helpdesk@bytespeed.com

Offline chemoti

  • Newbie
  • *
  • Posts: 1
Re: SP15 Laptop not charging battery
« Reply #3 on: April 09, 2014, 06:02:06 PM »

hi, first of all thanks for your guide, it's really the only one that could resurrect a laptop suffers from this problem.

I have a 15 sp UMA rev 2.1, the handset is a Olibook SP1500 but when I go to run the program in dos tells me "romid rom file is not compatible with existing bios romid" I might say, what's the problem?

zhauan

  • Guest
Re: SP15 Laptop not charging battery
« Reply #4 on: April 14, 2014, 04:33:31 PM »
Welcome the forums Chemoti!

I guess I am a little confused about your situation.  You mentioned a "Olibook SP1500" of which ByteSpeed does not sell.  If you attempted to flash a BIOS for a SP15-UMA in this machine please do not continue.  This could brick your board and make it completely non-functional.

However, if you do have a SP15, you should see on the bottom of your laptop, a black sticker that says the model number.  For the SP15's, there are 3 similar models: the SP15, SP15R-UMA, and SP15R-DESC.  Each of these boards have different BIOS flashes.

Please let me know what you find,
Zach
« Last Edit: April 29, 2014, 08:48:33 AM by zhauan »

Offline dengg

  • Newbie
  • *
  • Posts: 1
Re: SP15 Laptop not charging battery
« Reply #5 on: April 23, 2014, 10:27:39 PM »
Hi Zach,
I have a Pegatron SP15 laptop that does not charge the battery.  I  would like to flash the BIOS but i am not sure which SP15 i have (you've mentioned UMA, RMA, and DESC)

On the bottom of mine it only reads SP15
Is there a way to tell which SP15 it is?
What are the differences between those 3?
thank you

zhauan

  • Guest
Re: SP15 Laptop not charging battery
« Reply #6 on: April 29, 2014, 08:55:39 AM »
Thank you for joining up on the forums dengg!

I apologize for the mistake, especially one as important as this.  I've fixed my above post.  The SP15 you have should be the correct machine for this flash.  Please follow the directions above from tlesmeister.

If you have any questions or concerns about this flash, please contact us by email helpdesk@bytespeed.com or phone 1-877-553-0777.

Offline jbnewby67

  • Newbie
  • *
  • Posts: 2
Re: SP15 Laptop not charging battery
« Reply #7 on: June 11, 2014, 12:39:38 PM »
The download link in the main response does not have the files needed, and the download link which probably does have the bios and EC will not accept my username and password. I do not perceive why a user name and password to get from a place where I have already used them should be necessary, do you? Anyway, I have the battery problem and I need the downloads. Thanks for any help.

Offline KFritz

  • ByteSpeed Technician
  • Newbie
  • ***
  • Posts: 3
Re: SP15 Laptop not charging battery
« Reply #8 on: June 11, 2014, 04:45:15 PM »
The download link in the main response does not have the files needed, and the download link which probably does have the bios and EC will not accept my username and password. I do not perceive why a user name and password to get from a place where I have already used them should be necessary, do you? Anyway, I have the battery problem and I need the downloads. Thanks for any help.

Hi jbnewby67, please follow the information that tlesmeister has posted and let me know if that fixes the issue for you. I did check the links and they seem to be working for me. If they do not let me know and I will find another way to get you the files.

Offline jbnewby67

  • Newbie
  • *
  • Posts: 2
Re: SP15 Laptop not charging battery
« Reply #9 on: June 12, 2014, 05:45:15 PM »
When I try the link it demands my name and password, but when I enter them it then say "530 user jbnewby cannot log in." Thanks for your help. If you want to email me the file, it's jbnewby67@yahoo.com. Also, if I need a battery, can you tell me where to find one to buy? Thanks again so much. Bruce

zhauan

  • Guest
Re: SP15 Laptop not charging battery
« Reply #10 on: June 12, 2014, 11:07:02 PM »
Hello jbnewby67,

Thank you for joining the forums.  From what I gather, it appears you are having trouble logging into our FTP site.  As much as it would be nice to have a single sign on for our FTP and forums, at this time it is not possible.  We have created a universal login for such an occasion.  Please use the following username and password when it prompts you after clicking the aforementioned link:

Username: Bytespeed
Password: guest

I've emailed these files to you as well.  Please follow the instructions in this post.

To purchase a battery for a SP15, SP15R-UMA, or SP15R-DESC, please contact one of our sales staff.  You may reach us by dialing 1-877-553-0777 (toll free).

I hope I answered your questions completely, if not, please contact me at zhauan@bytespeed.com and I'll be sure to answer your inquiries.

Regards,
Zach
« Last Edit: June 13, 2014, 07:29:23 AM by zhauan »

Offline rgutshall

  • Newbie
  • *
  • Posts: 1
Re: SP15 Laptop not charging battery
« Reply #11 on: November 22, 2014, 07:56:52 AM »
Having the no charge issue.  Tried following the instructions BUT the username and password for the FTP site no longer works.

Are there new credentials?

Thanks

Offline dapted

  • Newbie
  • *
  • Posts: 2
Re: SP15 Laptop not charging battery
« Reply #12 on: February 24, 2015, 05:32:17 PM »
Hello Lucas.
I have the same battery charging issue.
I went to the drivers page but the bios and EC are not listed, I tried the FTP with anonymous and with the Bytespeed and Guest combination but no joy. Is there a new combination of username and password?

Offline dapted

  • Newbie
  • *
  • Posts: 2
Re: SP15 Laptop not charging battery
« Reply #13 on: February 24, 2015, 05:50:00 PM »
On second look my issue isn't quite the same. My issue is that the battery shows as not present even though it is. I have tried a new battery and still the same issue. I have disassembled and troublehot as best possible. there is zero voltage at the + and - terminals. From inside the computer looking down on the battery connector, pins 1 and 2 are larger and connect to ground so Im calling them the negative terminal. The other end of the connector pins 8 and 9 appear to be the positive terminal, but no voltage ever appears there. Pins 3 and 4 seem like some form of communication bus. Pins 5 6 and 7 are a mystery to me. Is there some connection here that has to have a certain resistance or voltage to turn on the battery or tell the charging circuit that a battery is present? Is there a schematic of the board or even of just the charging circuit that I can beg, borrow or steal?

Thanks

Dan Apted
CustomCPU
Anchorage, Alaska

Offline Meridor

  • Newbie
  • *
  • Posts: 3
Re: SP15 Laptop not charging battery
« Reply #14 on: October 12, 2015, 09:28:13 AM »
All are welcome! I have the same problem, can't find to buy the battery at a reasonable price, and there is no possibility to log into the FTP server! Please tell me where to buy it, or put the latest firmware for the BIOS SP15R-UMA?